Jump to content

amdamdeath

Mitglieder
  • Content Count

    6
  • Joined

  • Last visited

About amdamdeath

  • Rank
    Newbie

Recent Profile Visitors

595 profile views
  1. Hallo, ich benutze Dasylab mit 3 ICP-Con Modulen - funktioniert alles bestens. Jetzt würde ich gerne zusätzlich eine Messkarte zur Infrarot-Temp Messsung von Adamtech verwenden. Die ICP Con Module sind auf die Serielle Schnittstelle konfiguriert und auch das Adamtech Modul ist auf die serielle Schnittstelle (COM1 konfiguriert). In einem sortenreinen Schaltbild (jeweils nur ICP COn) oder das Adamtech-Modul funktioniert alles. Aber wenn ich die Module gemeinsam betreiben will, dann spuckt Dasylab immer einen Konfigurationsfehler der seriellen Schnittstelle aus. Kann man die Module nicht gemeinsam betreiben? LG, Adam
  2. Danke, da lag der Hund begragen. Die voreingestelle Abtastrate (global) war zu groß... Jetzt funktioniert es einwandfrei!
  3. Hallo, ich bin zwar noch immer Anfänger in DasyLAB, hab aber meine Steuerungen mit max 8 Modulen realisieren können. Zu meinem Problem: Ich habe bis jetzt nur einen Motor in der Drehzahl regeln müssen. Dazu habe ich die ICP-CON Karte 7021 (1 analoger Ausgang 4-20mA ) verwendet. Jetzt muss ich auch noch einen zweiten Motor regeln und hab mir dafür die ICP-CON Karte 7022 geholt (2 analoge Ausgänge 4-20mA) Das neue 7022 Modul reagiert aber nur mit einer ca. 10sec Verzögerung - d.h. ich schiebe den Regler am Eingang hoch und der Ausgangsstrom folgt erst spontan nach10sec. Ich habe das Modul GENAU gleich konfiguriert wie das 7021 (da ändert sich der Ausgang sofort). Sogar die Verkabelung habe ich getauscht. Ich habe wirklich alles ausprobiert und bin mit meinem Latein am Ende... Kann es sein das das 7022er Modul nicht einwandfrei unterstützt wird? Hat jemand noch einen Tipp für mich?
  4. Danke! Das synchrone Betätigen des Schalters "Schalter EIN" funktioniert jetzt wunderbar. Allerdings taucht jetzt schon das nächste Problem auf. Für "Schalter AUS" (damit Relais1 der Relaiskarte abfällt = Motor aus), habe ich die gleich Logik gewählt. Man sieht auch schön wie bei "STOP der Messung" der Handschalter auf "AUS" geht. NUR: Meine Relaiskarte folgt dem Signal des Handschalters nicht! Händisch kann ich dagegen einwandfrei schalten - dauert dann ca. 1sec bis es klackt. Meine Vermtung: "Stop der Messung" ist so abrupt, dass meine Relaiskarte nicht mehr zum Abschalten kommt. Frage: Kann man irgendwie eine globale Verzögerung einbauen, damit nach dem "Stop der Messung" alles noch 1-2 sec nachläuft? Lg, Andreas
  5. Hallo, ich stoße als Anfänger leider noch öfters an meine Grenzen. Mittlerweile habe ich zwar meine Regelstrecke durch das ausführliche Studium der Hilfe realisiert, aber jetzt steh ich vor einem (wahrscheinlich trivialem) Problem. Da ich mich jetzt schon stundenlange abgemüht habe, denke ich es ist besser die Profis zu fragen. Folgens Problem: Ich habe mehrere Meßwerterfassungskarten (ICP-CON Module) die ein Drehmoment, Temperatur usw aufnehmen. Das Ganze soll in einem Prüfzylus passieren der nur ca. 30sec dauert. Sobald ich die Messung startet liefern die Karten werte, die auch sogleich in ein X/Y Diagramm aufgezeichent werden - dazu läuft parallel die Uhr. Allerdings muss ich dazu erst mittels Relaiskarte einen FU starten. Eigentlich sollte der FU aber GLEICHZEITIG mit den Meßaufzeichnungen starten. Ich kann zwar über einen Start/Stop Taster die Messung beginnen bzw. stoppen, aber damit leider nicht die Relaiskarte verknüpfen. Also gehe ich bis dato so vor: Messung starten und dann über einen Handschalter die Relaiskarte ansteuern, damit der FU hochfährt. Wenn man sich aber verklickt, dann dauert dass 2-3 Sekunden und der Prüfzyklus wird ungenau. Und eigentlich will man ja vergleichbare Ergebnisse. Frage: Also wie ist es möglich dass ich meine Relaiskarte synchron mit dem Meßstart ansteuere ohne dass ich extra noch einen Schalter betätigen muss... Im Anhang mein derzeitiges Schaltbild - vielleicht wird dann alles ein wenig klarer. Lg, Andreas
  6. Hallo, ich bin ein Anfänger in DasyLAB und hab ein Regelungstechnisches Problem mit dem PID-Regler Aufgabe: Die Drehzahlregelung eines Asynchron-Motors. Der Motor soll konstant mit 2625 U/min laufen (Nenndrehzahl 2920), wobei eine immer stärker werdendes Lastmoment den Schlupf des Motors vergrößert. Angesteuert wird der Motor über einen FU. Der FU hat einen 4-20mA Eingang der die Frequenz proportional bis zum Maximum erhöht. Mein Ansatz: Die Ist-Drehzahl des Motors wird über eine Zählscheibe und ein Zählermodul mit induktiven Näherungsschalter erfasst. Das Zählermodul (ICP 7080) kann auch gleich den Frequenzwert (zB: 43Hz) ausgeben. Die Soll-Drehzahl wird statisch durch einen Sollwertgenerator (44,75Hz) erzeugt. Die Abweichung soll dann später an ein Ausgangsmodul (D/A) mit einem regelbaren 4-20mA Ausgang übergeben werden. Das Problem: Dem PID-Regler gefällt meine Umsetzung nicht besonders. Beim Start einer Messung wird immer mit folgender Fehlermeldung abgebrochen: PID-Regler: „Die Zeitinformation oder die Blocklänge der Datenströme ist unterschiedlich. Diese Kanäle können in diesem Modul nicht verknüpft werden. STOP!“ Ich habe schon die ganze Hilfe, Dokumentation und das Internet durchforstet. Leider ohne Erfolg. Wenn ich auch die ganze Doku zum PID-Regler lese, komme ich bei meinem spezifischen Problem nicht weiter. Irgendwo muß ich einen Denkfehler haben. Bin für jeden Tipp dankbar – auch für völlig andere Lösungsansätze, vielleicht geht es ja auch ohne PID-Regler. Lg, Andreas
×
×
  • Create New...